const regex = new RegExp(' ([\\'"`]) # capture this quote character
(?:\\\\.|(?!\\1).)*+ # any escaped character, or
# any character that isn\\'t the captured one
\\1 # the captured quote again
(*SKIP)(*FAIL) # ignore this
|
\\?\\?? # one or two question marks
|
::?\\w+ # word characters marked with one or two colons', 'g')
const str = `INSERT INTO xyz WHERE
a=?
and b="what?"
and ??="cheese"
and \`col?\`='OK'
and ::col='another'
and last!=:least`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}