$re = '~ ([\'"`]) # capture this quote character
(?:\\\\.|(?!\1).)*+ # any escaped character, or
# any character that isn\'t the captured one
\1 # the captured quote again
(*SKIP)(*FAIL) # ignore this
|
\?\?? # one or two question marks
|
::?\w+ # word characters marked with one or two colons~x';
$str = 'INSERT INTO xyz WHERE
a=?
and b="what?"
and ??="cheese"
and `col?`=\'OK\'
and ::col=\'another\'
and last!=:least';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);