using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s+|\s+$|\s+(?=\s)";
string substitution = @"";
string input = @" hello there spaces at end.
a b c d";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}