use strict;
my $str = ' hello there spaces at end.
a b c d';
my $regex = qr/^\s+|\s+$|\s+(?=\s)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";