$re = '/^\s+|\s+$|\s+(?=\s)/';
$str = ' hello there spaces at end.
a b c d';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;