using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-rule\s*(\""(\\\""|[^\""])*\"")";
string input = @"add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule ""HTTP.REQ.COOKIE.VALUE(\""JSESSIONID\"")"" -resRule ""HTTP.RES.SET_COOKIE.COOKIE(\""JSESSIONID\"").VALUE(\""JSESSIONID\"")"" -cltTimeout 600 -td 1
add lb vserver VS_ssl_8443_pega.awc_prd SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule ""HTTP.REQ.COOKIE.VALUE(\""jsessionid\"") ALT HTTP.REQ.URL.BEFORE_STR(\""?\"").AFTER_STR(\"";jsessionid=\"") ALT HTTP.REQ.URL.AFTER_STR(\"";jsessionid=\"")"" -resRul";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}