# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"-rule\s*(\"(\\\"|[^\"])*\")"
test_str = ("add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"JSESSIONID\\\")\" -resRule \"HTTP.RES.SET_COOKIE.COOKIE(\\\"JSESSIONID\\\").VALUE(\\\"JSESSIONID\\\")\" -cltTimeout 600 -td 1\n\n"
"add lb vserver VS_ssl_8443_pega.awc_prd SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\" -resRul")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.