import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-rule\\s*(\\\"(\\\\\\\"|[^\\\"])*\\\")";
final String string = "add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"JSESSIONID\\\")\" -resRule \"HTTP.RES.SET_COOKIE.COOKIE(\\\"JSESSIONID\\\").VALUE(\\\"JSESSIONID\\\")\" -cltTimeout 600 -td 1\n\n"
+ "add lb vserver VS_ssl_8443_pega.awc_prd SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule \"HTTP.REQ.COOKIE.VALUE(\\\"jsessionid\\\") ALT HTTP.REQ.URL.BEFORE_STR(\\\"?\\\").AFTER_STR(\\\";jsessionid=\\\") ALT HTTP.REQ.URL.AFTER_STR(\\\";jsessionid=\\\")\" -resRul";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}