$re = '/-rule\s*(\"(\\\\\"|[^\"])*\")/m';
$str = 'add lb vserver VS_ssl_443_testapps SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\\"JSESSIONID\\")" -resRule "HTTP.RES.SET_COOKIE.COOKIE(\\"JSESSIONID\\").VALUE(\\"JSESSIONID\\")" -cltTimeout 600 -td 1
add lb vserver VS_ssl_8443_pega.awc_prd SSL 0.0.0.0 0 -persistenceType RULE -timeout 30 -rule "HTTP.REQ.COOKIE.VALUE(\\"jsessionid\\") ALT HTTP.REQ.URL.BEFORE_STR(\\"?\\").AFTER_STR(\\";jsessionid=\\") ALT HTTP.REQ.URL.AFTER_STR(\\";jsessionid=\\")" -resRul';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);