package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<uuid>[0-9:A-z\r\n]+) at line number (?<row>\d+)`)
var str = `2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:DEF1:123890AB12345678 at line number 171
2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:
DEF1:
123890AB12345678 at line number 171`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}