$re = '/(?<uuid>[0-9:A-z\r\n]+) at line number (?<row>\d+)/m';
$str = '2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:DEF1:123890AB12345678 at line number 171
2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:
DEF1:
123890AB12345678 at line number 171';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);