const regex = /(?<uuid>[0-9:A-z\r\n]+) at line number (?<row>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<uuid>[0-9:A-z\\r\\n]+) at line number (?<row>\\d+)', 'gm')
const str = `2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:DEF1:123890AB12345678 at line number 171
2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:
DEF1:
123890AB12345678 at line number 171`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}