use strict;
my $str = '2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:DEF1:123890AB12345678 at line number 171
2016/07/02 11:23:45 error nullpointerexception 123ACA12:2345:6785:
DEF1:
123890AB12345678 at line number 171';
my $regex = qr/(?<uuid>[0-9:A-z\r\n]+) at line number (?<row>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}