using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((\d{4,}(?:[\.,]\d+)?)|((\d{1,3}(?:((\.)|,)\d{1,3})?(?:\6\d{1,3})*(?:(?(7),|\.)\d+)?)))\s*(?:[a-zA-Z]*))";
string input = @"123mm
123mm
123 mm
123 mm
123MM
123MM
123 MM
123 MM
123,45mm
123.45mm
123,45 mm
123.45 mm
123,45MM
123.45MM
123,45 MM
123.45 MM
1.234,56mm
1,234.56mm
1.234,56 mm
1,234.56 mm
1.234,56MM
1,234.56MM
1.234,56 MM
1,234.56 MM
4.321.234,56mm
4,321,234.56mm
4.321.234,56 mm
4,321,234.56 mm
4.321.234,56MM
4,321,234.56MM
4.321.234,56 MM
4,321,234.56 MM
4.321,234.56mm
4,321,234,56mm
4.321.234,56 mm
4,321.234.56 mm
4.321.234,56MM
4.321,234.56MM
4.321.234,56 MM
123,499,321,234.56 MMillimeter George Washington
123456.23mm
123456,23mm
123456..23mm
123456.,23mm
123,456,789.23
1.234,56MM 1,234.56MM 1.234,56 MM ,234.56 MM Alabama
4.321.234,56mm 4,321,234.56mm 4.321.234,56 mm 4,321,234.56 mm South Africa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}