use strict;
my $str = '123mm
123mm
123 mm
123 mm
123MM
123MM
123 MM
123 MM
123,45mm
123.45mm
123,45 mm
123.45 mm
123,45MM
123.45MM
123,45 MM
123.45 MM
1.234,56mm
1,234.56mm
1.234,56 mm
1,234.56 mm
1.234,56MM
1,234.56MM
1.234,56 MM
1,234.56 MM
4.321.234,56mm
4,321,234.56mm
4.321.234,56 mm
4,321,234.56 mm
4.321.234,56MM
4,321,234.56MM
4.321.234,56 MM
4,321,234.56 MM
4.321,234.56mm
4,321,234,56mm
4.321.234,56 mm
4,321.234.56 mm
4.321.234,56MM
4.321,234.56MM
4.321.234,56 MM
123,499,321,234.56 MMillimeter George Washington
123456.23mm
123456,23mm
123456..23mm
123456.,23mm
123,456,789.23
1.234,56MM 1,234.56MM 1.234,56 MM ,234.56 MM Alabama
4.321.234,56mm 4,321,234.56mm 4.321.234,56 mm 4,321,234.56 mm South Africa';
my $regex = qr/(((\d{4,}(?:[\.,]\d+)?)|((\d{1,3}(?:((\.)|,)\d{1,3})?(?:\6\d{1,3})*(?:(?(7),|\.)\d+)?)))\s*(?:[a-zA-Z]*))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}