import re
regex = re.compile(r"(((\d{4,}(?:[\.,]\d+)?)|((\d{1,3}(?:((\.)|,)\d{1,3})?(?:\6\d{1,3})*(?:(?(7),|\.)\d+)?)))\s*(?:[a-zA-Z]*))", flags=re.MULTILINE)
test_str = ("123mm\n"
"123mm\n"
"123 mm\n"
"123 mm\n"
"123MM\n"
"123MM\n"
"123 MM\n"
"123 MM\n\n"
"123,45mm\n"
"123.45mm\n"
"123,45 mm\n"
"123.45 mm\n"
"123,45MM\n"
"123.45MM\n"
"123,45 MM\n"
"123.45 MM\n\n"
"1.234,56mm\n"
"1,234.56mm\n"
"1.234,56 mm\n"
"1,234.56 mm\n"
"1.234,56MM\n"
"1,234.56MM\n"
"1.234,56 MM\n"
"1,234.56 MM\n\n"
"4.321.234,56mm\n"
"4,321,234.56mm\n"
"4.321.234,56 mm\n"
"4,321,234.56 mm\n"
"4.321.234,56MM\n"
"4,321,234.56MM\n"
"4.321.234,56 MM\n"
"4,321,234.56 MM\n\n"
"4.321,234.56mm\n"
"4,321,234,56mm\n"
"4.321.234,56 mm\n"
"4,321.234.56 mm\n"
"4.321.234,56MM\n"
"4.321,234.56MM\n"
"4.321.234,56 MM\n"
"123,499,321,234.56 MMillimeter George Washington\n\n"
"123456.23mm\n"
"123456,23mm\n"
"123456..23mm\n"
"123456.,23mm\n"
"123,456,789.23\n\n"
"1.234,56MM 1,234.56MM 1.234,56 MM ,234.56 MM Alabama\n\n"
"4.321.234,56mm 4,321,234.56mm 4.321.234,56 mm 4,321,234.56 mm South Africa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")