import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((\\d{4,}(?:[\\.,]\\d+)?)|((\\d{1,3}(?:((\\.)|,)\\d{1,3})?(?:\\6\\d{1,3})*(?:(?(7),|\\.)\\d+)?)))\\s*(?:[a-zA-Z]*))";
final String string = "123mm\n"
+ "123mm\n"
+ "123 mm\n"
+ "123 mm\n"
+ "123MM\n"
+ "123MM\n"
+ "123 MM\n"
+ "123 MM\n\n"
+ "123,45mm\n"
+ "123.45mm\n"
+ "123,45 mm\n"
+ "123.45 mm\n"
+ "123,45MM\n"
+ "123.45MM\n"
+ "123,45 MM\n"
+ "123.45 MM\n\n"
+ "1.234,56mm\n"
+ "1,234.56mm\n"
+ "1.234,56 mm\n"
+ "1,234.56 mm\n"
+ "1.234,56MM\n"
+ "1,234.56MM\n"
+ "1.234,56 MM\n"
+ "1,234.56 MM\n\n"
+ "4.321.234,56mm\n"
+ "4,321,234.56mm\n"
+ "4.321.234,56 mm\n"
+ "4,321,234.56 mm\n"
+ "4.321.234,56MM\n"
+ "4,321,234.56MM\n"
+ "4.321.234,56 MM\n"
+ "4,321,234.56 MM\n\n"
+ "4.321,234.56mm\n"
+ "4,321,234,56mm\n"
+ "4.321.234,56 mm\n"
+ "4,321.234.56 mm\n"
+ "4.321.234,56MM\n"
+ "4.321,234.56MM\n"
+ "4.321.234,56 MM\n"
+ "123,499,321,234.56 MMillimeter George Washington\n\n"
+ "123456.23mm\n"
+ "123456,23mm\n"
+ "123456..23mm\n"
+ "123456.,23mm\n"
+ "123,456,789.23\n\n"
+ "1.234,56MM 1,234.56MM 1.234,56 MM ,234.56 MM Alabama\n\n"
+ "4.321.234,56mm 4,321,234.56mm 4.321.234,56 mm 4,321,234.56 mm South Africa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}