using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\[(No|S\d( Act \d)?|Lore) Spoilers\])?[^\[\]\n]+$";
string input = @"[No Spoilers] Here's The Title
[S2 Act 2 Spoilers] Here's The Title
[S2 Act 7 Spoilers] Here's The Title
[S7 Act 7 Spoilers] Here's The Title
Here's The Title
Here's The Title [No Spoilers]
[Invalid Spoilers] Here's The Title";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}