package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\[(No|S\d( Act \d)?|Lore) Spoilers\])?[^\[\]\n]+$`)
var str = `[No Spoilers] Here's The Title
[S2 Act 2 Spoilers] Here's The Title
[S2 Act 7 Spoilers] Here's The Title
[S7 Act 7 Spoilers] Here's The Title
Here's The Title
Here's The Title [No Spoilers]
[Invalid Spoilers] Here's The Title`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}