re = /^(\[(No|S\d( Act \d)?|Lore) Spoilers\])?[^\[\]\n]+$/m
str = '[No Spoilers] Here\'s The Title
[S2 Act 2 Spoilers] Here\'s The Title
[S2 Act 7 Spoilers] Here\'s The Title
[S7 Act 7 Spoilers] Here\'s The Title
Here\'s The Title
Here\'s The Title [No Spoilers]
[Invalid Spoilers] Here\'s The Title'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end