// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\[(No|S\d( Act \d)?|Lore) Spoilers\])?[^\[\]\n]+$").unwrap();
let string = "[No Spoilers] Here's The Title
[S2 Act 2 Spoilers] Here's The Title
[S2 Act 7 Spoilers] Here's The Title
[S7 Act 7 Spoilers] Here's The Title
Here's The Title
Here's The Title [No Spoilers]
[Invalid Spoilers] Here's The Title";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}