using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ANCBTH((?:\s?\d+)*)";
string input = @"ANCBTH2016100931011730300000458
ANCBTH 2016100931011730300000458
ANCBTH 20161009 31011730300000458";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}