re = /ANCBTH((?:\s?\d+)*)/m
str = 'ANCBTH2016100931011730300000458
ANCBTH 2016100931011730300000458
ANCBTH 20161009 31011730300000458'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end