// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ANCBTH((?:\s?\d+)*)").unwrap();
let string = "ANCBTH2016100931011730300000458
ANCBTH 2016100931011730300000458
ANCBTH 20161009 31011730300000458";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}