import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ANCBTH((?:\\s?\\d+)*)";
final String string = "ANCBTH2016100931011730300000458\n"
+ "ANCBTH 2016100931011730300000458\n"
+ "ANCBTH 20161009 31011730300000458";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}