use strict;
my $str = 'Emulex LPe16000';
my $regex = qr/Emulex\s+([A-Z]+[a-z]+[0-9]+)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";