# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\s+'.+)'(?:(?=' \+)\1|)//gm;t' <<< " 'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_ID'
'is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
"