using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s+'.+)'(?:(?=' \+)\1|)";
string substitution = @"";
string input = @" 'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_ID'
'is null and v.Block<>1')
'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}