#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*\[detailOutput] => .*(?:\R(?!\h*\[authorizationCode]).*)*\R\h*(\[authorizationCode] => \d+)(?:\R(?!\h*\[amount]).*)*\R\h*(\[amount] => \d+)"
Local $sString = "[transactionDetails] => wsTransactionDetail Object" & @CRLF & _
" (" & @CRLF & _
" [sharesAmount] => " & @CRLF & _
" [sharesNumber] => " & @CRLF & _
" [amount] => 33450" & @CRLF & _
" [commerceCode] => 1234567890" & @CRLF & _
" [buyOrder] => 123321" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
"[detailOutput] => wsTransactionDetailOutput Object" & @CRLF & _
" (" & @CRLF & _
" [authorizationCode] => 001122" & @CRLF & _
" [paymentTypeCode] => VD" & @CRLF & _
" [responseCode] => 0" & @CRLF & _
" [sharesNumber] => 0" & @CRLF & _
" [amount] => 33450" & @CRLF & _
" [commerceCode] => 1234567890" & @CRLF & _
" [buyOrder] => 123321" & @CRLF & _
" )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")