import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*\\[detailOutput] => .*(?:\\R(?!\\h*\\[authorizationCode]).*)*\\R\\h*(\\[authorizationCode] => \\d+)(?:\\R(?!\\h*\\[amount]).*)*\\R\\h*(\\[amount] => \\d+)";
final String string = "[transactionDetails] => wsTransactionDetail Object\n"
+ " (\n"
+ " [sharesAmount] => \n"
+ " [sharesNumber] => \n"
+ " [amount] => 33450\n"
+ " [commerceCode] => 1234567890\n"
+ " [buyOrder] => 123321\n"
+ " )\n\n"
+ "[detailOutput] => wsTransactionDetailOutput Object\n"
+ " (\n"
+ " [authorizationCode] => 001122\n"
+ " [paymentTypeCode] => VD\n"
+ " [responseCode] => 0\n"
+ " [sharesNumber] => 0\n"
+ " [amount] => 33450\n"
+ " [commerceCode] => 1234567890\n"
+ " [buyOrder] => 123321\n"
+ " )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}