import re
regex = re.compile(r"^\h*\[detailOutput] => .*(?:\R(?!\h*\[authorizationCode]).*)*\R\h*(\[authorizationCode] => \d+)(?:\R(?!\h*\[amount]).*)*\R\h*(\[amount] => \d+)", flags=re.MULTILINE)
test_str = ("[transactionDetails] => wsTransactionDetail Object\n"
" (\n"
" [sharesAmount] => \n"
" [sharesNumber] => \n"
" [amount] => 33450\n"
" [commerceCode] => 1234567890\n"
" [buyOrder] => 123321\n"
" )\n\n"
"[detailOutput] => wsTransactionDetailOutput Object\n"
" (\n"
" [authorizationCode] => 001122\n"
" [paymentTypeCode] => VD\n"
" [responseCode] => 0\n"
" [sharesNumber] => 0\n"
" [amount] => 33450\n"
" [commerceCode] => 1234567890\n"
" [buyOrder] => 123321\n"
" )")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")