$re = '/^\h*\[detailOutput] => .*(?:\R(?!\h*\[authorizationCode]).*)*\R\h*(\[authorizationCode] => \d+)(?:\R(?!\h*\[amount]).*)*\R\h*(\[amount] => \d+)/m';
$str = '[transactionDetails] => wsTransactionDetail Object
(
[sharesAmount] =>
[sharesNumber] =>
[amount] => 33450
[commerceCode] => 1234567890
[buyOrder] => 123321
)
[detailOutput] => wsTransactionDetailOutput Object
(
[authorizationCode] => 001122
[paymentTypeCode] => VD
[responseCode] => 0
[sharesNumber] => 0
[amount] => 33450
[commerceCode] => 1234567890
[buyOrder] => 123321
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);