using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(#Test).*(\s*;.*)*";
string substitution = @"";
string input = @"(?<!^$)
; #Test #1
; bbbb
; #Test #1
; aaa
; #Test #1
; bbbb
xxxx
;#Test
;#Test
x
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}