// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(#Test).*(\s*;.*)*").unwrap();
let string = "(?<!^$)
; #Test #1
; bbbb
; #Test #1
; aaa
; #Test #1
; bbbb
xxxx
;#Test
;#Test
x
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}