re = /\s*(#Test).*(\s*;.*)*/m
str = '(?<!^$)
; #Test #1
; bbbb
; #Test #1
; aaa
; #Test #1
; bbbb
xxxx
;#Test
;#Test
x
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result