$re = '/\s*(#Test).*(\s*;.*)*/m';
$str = '(?<!^$)
; #Test #1
; bbbb
; #Test #1
; aaa
; #Test #1
; bbbb
xxxx
;#Test
;#Test
x
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;