import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<body(.[^>\\{\\}]*(?:\\{+[^\\}]*\\}+[^>\\{\\}]*)*)>";
final String string = "<other tag><body class=\"template-{{ template | replace: '.', ' ' | truncatewords: \n"
+ "1, '' }}{% if promo %}has-promo{% endif %} {% if products.size > 1 \n"
+ "%}has-related-products{% endif %} {% if settings.product-hover == \n"
+ "'quick-shop' %}has-quick-shop{% endif %} loading\" ></other tag>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}