re = /<body(.[^>{}]*(?:{+[^}]*}+[^>{}]*)*)>/
str = '<other tag><body class="template-{{ template | replace: \'.\', \' \' | truncatewords:
1, \'\' }}{% if promo %}has-promo{% endif %} {% if products.size > 1
%}has-related-products{% endif %} {% if settings.product-hover ==
\'quick-shop\' %}has-quick-shop{% endif %} loading" ></other tag>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end