const regex = /<body(.[^>{}]*(?:{+[^}]*}+[^>{}]*)*)>/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<body(.[^>{}]*(?:{+[^}]*}+[^>{}]*)*)>', 's')
const str = `<other tag><body class="template-{{ template | replace: '.', ' ' | truncatewords:
1, '' }}{% if promo %}has-promo{% endif %} {% if products.size > 1
%}has-related-products{% endif %} {% if settings.product-hover ==
'quick-shop' %}has-quick-shop{% endif %} loading" ></other tag>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}