import re
regex = re.compile(r"<body(.[^>{}]*(?:{+[^}]*}+[^>{}]*)*)>", flags=re.DOTALL)
test_str = ("<other tag><body class=\"template-{{ template | replace: '.', ' ' | truncatewords: \n"
"1, '' }}{% if promo %}has-promo{% endif %} {% if products.size > 1 \n"
"%}has-related-products{% endif %} {% if settings.product-hover == \n"
"'quick-shop' %}has-quick-shop{% endif %} loading\" ></other tag>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")