#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})"
Local $sString = "m.goksu0234@gmail.com" & @CRLF & _
"ahmetgoksu34@gmail.com.tr" & @CRLF & _
"kjdhfahadsfkj@hotmail.com.tr" & @CRLF & _
"jhkgsfglj0933@yahşoo.org" & @CRLF & _
"vjkaov_oka,kg.hot@bilgiedu.net" & @CRLF & _
"vjkaov_okakg.hot@bilgiedu.n44ff" & @CRLF & _
"kvkjak v,,@hotmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")