// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})").unwrap();
let string = "m.goksu0234@gmail.com
ahmetgoksu34@gmail.com.tr
kjdhfahadsfkj@hotmail.com.tr
jhkgsfglj0933@yahşoo.org
vjkaov_oka,kg.hot@bilgiedu.net
vjkaov_okakg.hot@bilgiedu.n44ff
kvkjak v,,@hotmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}