const regex = /^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9\\._]+)@([a-z]+)\\.([a-z]{2,4})', 'gm')
const str = `m.goksu0234@gmail.com
ahmetgoksu34@gmail.com.tr
kjdhfahadsfkj@hotmail.com.tr
jhkgsfglj0933@yahşoo.org
vjkaov_oka,kg.hot@bilgiedu.net
vjkaov_okakg.hot@bilgiedu.n44ff
kvkjak v,,@hotmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}