import re
regex = re.compile(r"^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})", flags=re.MULTILINE)
test_str = ("m.goksu0234@gmail.com\n"
"ahmetgoksu34@gmail.com.tr\n"
"kjdhfahadsfkj@hotmail.com.tr\n"
"jhkgsfglj0933@yahşoo.org\n"
"vjkaov_oka,kg.hot@bilgiedu.net\n"
"vjkaov_okakg.hot@bilgiedu.n44ff\n"
"kvkjak v,,@hotmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")