using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\btest\b.*).*(\btest\b).*";
string substitution = @"$1";
string input = @"test some other words that comes after
some other words before test some other words that comes after";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}