const regex = /(?=.*\btest\b.*).*(\btest\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\btest\\b.*).*(\\btest\\b).*', 'gm')
const str = `test some other words that comes after
some other words before test some other words that comes after`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);