use strict;
my $str = 'test some other words that comes after
some other words before test some other words that comes after';
my $regex = qr/(?=.*\btest\b.*).*(\btest\b).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";