re = /(?=.*\btest\b.*).*(\btest\b).*/m
str = 'test some other words that comes after
some other words before test some other words that comes after'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result