import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<v>截.*?股[份票\\d,共计股万]+(.*(不存在|[占其]).*?(承诺|股[本份]).*?)?)[,。]";
final String string = "作。截至本公告披露日,郁琴芬女士持有本公司股份144,300,000股,占公司总股本的8.09%。郁琴芬及其一致行动人合计持有公司股份610,441,454股,占公司总股本的34.23%。";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}