re = /(?P<v>截.*?股[份票\d,共计股万]+(.*(不存在|[占其]).*?(承诺|股[本份]).*?)?)[,。]/m
str = '作。截至本公告披露日,郁琴芬女士持有本公司股份144,300,000股,占公司总股本的8.09%。郁琴芬及其一致行动人合计持有公司股份610,441,454股,占公司总股本的34.23%。'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end